New Question

Hyper-V: Device not found?

asked 2015-02-13 09:56:13 +0300

salacryl gravatar image

updated 2015-02-13 10:44:59 +0300


I'm new to openstack and figure out how to manage to get a working hyper-v 2012 compute agent (thx to claoudbase).

Except: the network adapter does't get a binding. What I found is: /opt/stack/logs/screen-q-svc.log:2015-02-10 11:09:18.100 WARNING neutron.plugins.ml2.rpc [req-f2558533-d162-4e09-a21a-299e5ed4847f None None] Device Netzwerkkarte requested by agent hyperv_XXXX not found in database /opt/stack/logs/screen-q-svc.log:2015-02-10 11:10:27.996 WARNING neutron.plugins.ml2.managers [req-18c5e929-ec8f-4677-8aa9-207bf4ac115b neutron 955a0fb7d0794ad4b5f9d18ee4d203a1] Failed to bind port 3cb436be-30af-47f1-b0fb-fd88e6afeaca on host XXXX

is it possible that the german name for the device is not supported? If so, How can I change that? oddly the device get an ID which could not get a port binding.

WARNING neutron.plugins.ml2.managers [req-18c5e929-ec8f-4677-8aa9-207bf4ac115b neutron 955a0fb7d0794ad4b5f9d18ee4d203a1] Failed to bind port 3cb436be-30af-47f1-b0fb-fd88e6afeaca on host XXXX

Any suggestions?

Greetings, Björn

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted

answered 2015-02-17 12:36:45 +0300

salacryl gravatar image


got it. Devstack created just a vxlan network. I've created a new VLAN-Network and it worked,


Greetings, Björn

edit flag offensive delete link more

answered 2015-02-16 18:59:40 +0300

Claudiu Belu gravatar image


Well, the first warning, regarding the Device Netzwerkkarte shouldn't be a concern. From what I can tell, the virtual machine having a Network Adapter with such a name was not created by OpenStack, meaning it will not be managed by neutron (hence, it is not in the database). All virtual machines created by OpenStack will have Network Adapters having UUIDs as names, similar to your 3cb436be-30af-47f1-b0fb-fd88e6afeaca.

As for the second warning, there could be a couple of things which could generate it. For example, executing this command

neutron port-show 3cb436be-30af-47f1-b0fb-fd88e6afeaca

will probably yield binding:vif_details = binding_failed or something similar.

This can mean one of a couple of things:

  1. The Neutron Hyper-V Agent is down. Check its state by running:

    neutron agent-list

    The agent should be alive (or :-)) for the ports to be bound. If the agent is down, please check the logs in your Hyper-V node: C:\OpenStack\Logs\neutron.log

  2. You didn't add the Hyper-V Mechanism to ml2_conf.ini. Make sure that your Networking Node, hosting neutron has this in the file: /etc/neutron/plugins/ml2/ml2_conf.ini``:

    tenant_network_types = vlan
    type_drivers = local,flat,vlan,gre,vxlan
    mechanism_drivers = openvswitch,hyperv

    Any changes to this file will require the q-svc / q-agt services to be restarted, in order to take effect.

    Hyper-V supports VLAN, flat and local as tenantnetworktypes. Also, you can have any other mechanism_drivers in the list.

  3. Some error in the Hyper-V Neutron Agent, but highly unlikely, since the port would still be bound. But, if it is the case, please provide the neutron log file from your Hyper-V node.

Let me know if this helps, or if further investigation is required. :)

Best regards,

Claudiu Belu

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2015-02-13 09:56:13 +0300

Seen: 888 times

Last updated: Feb 17 '15