New Question
0

Windows 2016 - cloudbase error - device not ready

asked 2020-07-08 02:43:53 +0200

rliberty gravatar image

I see a few posts for this issue, with no answers.

2016 Template on VMmware 6.7. I have a local user named "cloudbase" created and set as a local administrator with logon as a service rights.

Here's the cloudbase-init.log: 2020-07-07 23:00:30.230 2012 DEBUG cloudbaseinit.osutils.windows [-] Creating logon session for user: True\cloudbase createuserlogon_session C:\Program Files\Cloudbase Solutions\Cloudbase-Init\Python\lib\site-packages\cloudbaseinit\osutils\windows.py:649

2020-07-07 23:00:32.511 2012 ERROR cloudbaseinit.plugins.windows.createuser [-] Cannot create a user logon session for user: "cloudbase": cloudbaseinit.exception.WindowsCloudbaseInitException: Cannot load user profile: 'The device is not ready.'

2020-07-07 23:00:32.511 2012 ERROR cloudbaseinit.plugins.windows.createuser Traceback (most recent call last): 2020-07-07 23:00:32.511 2012 ERROR cloudbaseinit.plugins.windows.createuser File "C:\Program Files\Cloudbase Solutions\Cloudbase-Init\Python\lib\site-packages\cloudbaseinit\plugins\windows\createuser.py", line 32, in createuserlogon 2020-07-07 23:00:32.511 2012 ERROR cloudbaseinit.plugins.windows.createuser True) 2020-07-07 23:00:32.511 2012 ERROR cloudbaseinit.plugins.windows.createuser File "C:\Program Files\Cloudbase Solutions\Cloudbase-Init\Python\lib\site-packages\cloudbaseinit\osutils\windows.py", line 670, in createuserlogonsession 2020-07-07 23:00:32.511 2012 ERROR cloudbaseinit.plugins.windows.createuser "Cannot load user profile: %r") 2020-07-07 23:00:32.511 2012 ERROR cloudbaseinit.plugins.windows.createuser cloudbaseinit.exception.WindowsCloudbaseInitException: Cannot load user profile: 'The device is not ready.' 2020-07-07 23:00:32.511 2012 ERROR cloudbaseinit.plugins.windows.createuser 2020-07-07 23:00:32.527 2012 INFO cloudbaseinit.init [-] Executing plugin 'SetUserPasswordPlugin' 2020-07-07 23:00:32.527 2012 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.osutils.windows.WindowsUtils' load_class C:\Program Files\Cloudbase Solutions\Cloudbase-Init\Python\lib\site-packages\cloudbaseinit\utils\classloader.py:27

But then, its able to set the password for the cloudbase account?

2020-07-07 23:00:32.527 2012 DEBUG cloudbaseinit.plugins.common.setuserpassword [-] Generating a random user password setpassword C:\Program Files\Cloudbase Solutions\Cloudbase-Init\Python\lib\site-packages\cloudbaseinit\plugins\common\setuserpassword.py:87 2020-07-07 23:00:32.527 2012 INFO cloudbaseinit.plugins.common.setuserpassword [-] Password succesfully updated for user cloudbase

I did login with the account before sysprep to validate the account logon.

Thanks for any input!

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2020-07-13 12:51:45 +0200

avladu gravatar image

Hello,

This looks like a concurrency issue at the moment where cloudbase-init tries to create the logon session and the Windows OS state. For the moment, I cannot reproduce the error, but I know this definitely happens to multiple users, probably because of laggy systems, where some Windows services are not properly initialized when the call to create the logon session is made.

At this moment, what we can try is to add a retry when this error happens.

If I create a custom cloudbase-init installer with the patch, can you try it out?

Thank you.

edit flag offensive delete link more

Comments

Yes, I definitely can try it. Much appreciated!

rliberty gravatar imagerliberty ( 2020-07-20 21:26:35 +0200 )edit

From here (artifacts tab) you can download a built MSI with the possible fix (zipped): https://github.com/ader1990/cloudbase-init-installer-1/actions/runs/167211654 .

avladu gravatar imageavladu ( 2020-07-21 11:14:28 +0200 )edit

Did this solve the issue and/or get merged in to the main code base? I see the patched version is no longer available to download so I can't try it. I am having the same error.

vthyng gravatar imagevthyng ( 2021-01-08 23:13:42 +0200 )edit

The patches version is still available, but the link was masked by ask (it was adding a trailing garbage at the end of the url, fixed it).

avladu gravatar imageavladu ( 2021-01-13 12:59:32 +0200 )edit

When I go to that link it seems that the artifact is expired. I can not find a way to download it: 'CloudbaseInit x64 MSI Expired 53 MB'

vthyng gravatar imagevthyng ( 2021-01-13 21:37:07 +0200 )edit
0

answered 2021-01-09 00:56:32 +0200

vthyng gravatar image

As a work around, I tried changing cloudbase-init service to delayed start and that has worked to get me passed this error.

edit flag offensive delete link more

Comments

sorry to trouble you ,.sir ,i also have this issue when i start up os with cloudebase. may i ask you how to delayed start the cloudbase-init service ? my email is kevin.x.liang@foxmail.com , i am looking forward to your reply

KevinLiangX gravatar imageKevinLiangX ( 2021-01-26 03:30:23 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-07-08 02:43:53 +0200

Seen: 599 times

Last updated: Jan 09