New Question
0

Newbie with cloudbase-init, seems is not working :(

asked 2021-01-04 17:54:11 +0300

jmginer gravatar image

updated 2021-01-04 17:55:03 +0300

Hi, I'm trying out cloudbase-init on a Windows 10 on Proxmox. But I can't get it to work... I tell you what I have done:

  • I install a Windows 10 ISO on a KVM VPS.
  • I configure the network and download the CloudbaseInitSetup112x64 installer
  • I run the installer:
    • Check the box to install the cloidinit service locally
    • I do not check the sysprep

When it is finished, I restart the VPS and check that the user Admin has not been created... I understand therefore that nothing has worked...

Do I do something wrong? Thanks for the information!

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2021-01-11 13:52:24 +0300

jmginer gravatar image

Hello and thanks @avladu , Proxmox Cloud-init generates a CDROM in the VPS with 3 files:

META_DATA

instance-id: a22ff9b4658f7fe2074610c77f1d3c0fb9cea997

NETWORK_CONFIG

version: 1
config:
    - type: physical
      name: eth0
      mac_address: 'xx:xx:xx:xx:xx:xx'
      subnets:
      - type: static
        address: '5.0.0.0'
        netmask: '255.255.255.0'
        gateway: '5.0.0.1'
    - type: nameserver
      address:
      - '8.8.8.8'
      search:
      - 'domain.network'

USER_DATA

#cloud-config
hostname: windows
manage_etc_hosts: true
fqdn: windows.test
user: ginernet
password: $5$IDHmkfZD$kjhAWLKSHKJ/JKAHSDKJkajhds/AY7cbcAsEsKkwWwu8
chpasswd:
  expire: False
users:
  - default
package_upgrade: true
edit flag offensive delete link more

Comments

The metadata format looks to be in the NoCloud format: https://cloudbase-init.readthedocs.io/en/latest/services.html#nocloud-configuration-drive But note that the NoCloud implementation uses - (hyphen) and not _ (underscore). Are you sure that the metadata file names use _ (underscore)?

avladu gravatar imageavladu ( 2021-01-13 12:53:05 +0300 )edit

I understand what you mean, this needs a patch for cloudbase-init to work. If I share a patched cloudbase-init installer, can you test it?

avladu gravatar imageavladu ( 2021-01-22 13:28:45 +0300 )edit

Sure! Feel free to contact me by e-mail directly. Thanks!

jmginer gravatar imagejmginer ( 2021-01-22 19:30:54 +0300 )edit

Hello @avladu any info?

jmginer gravatar imagejmginer ( 2021-02-09 18:11:36 +0300 )edit
0

answered 2021-01-05 19:04:39 +0300

avladu gravatar image

Hello,

Cloudbase-Init (like cloud-init) is an agent (an executable in its primary form) that configures an OS instance (Windows/Linux or Unix) at first boot using metadata (information) provided by the platform that created that instance (example: OpenStack, Azure, AWS).

In your case, Proxmox (after all I know) is just a VM lifecycle manager and does not provide the metadata in any form (config-drive or http). The easiest method to provide metadata is to attach at boot time an ISO with the relevant metadata structure and format. Example of metadata folder structure and content here (in order to create a metadata ISO): https://github.com/cloudbase/cloudbas... .

Can you elaborate on what you are trying to achieve in your case? Most likely, there are multiple ways to resolve your initial issue.

Thank you,
Adrian

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2021-01-04 17:54:11 +0300

Seen: 188 times

Last updated: Jan 11