New Question
0

set vlanID in meta-data

asked 2021-11-14 13:24:06 +0200

updated 2021-11-14 13:25:13 +0200

Hello how can I set vlanid in metadata? this is my meta-data that everythings work but vlanid not set.

instance-id: abc
network-interfaces: |
  iface eth0 inet static
  address 192.168.1.120
  netmask 255.255.255.0
  broadcast 192.168.1.255
  gateway 192.168.1.1
  vlan_name eth0
  vlan_link eth0
  vlan_id 100
  dns-nameservers 8.8.8.8

hostname: abc
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2021-11-15 23:07:20 +0200

avladu gravatar image

Hello,

Cloudbase-init does not support vlans defined in the legacy network metadata (debian format). Please see the documentation https://cloudbase-init.readthedocs.io..., where network metadata in the cloud-init format is presented: https://cloudinit.readthedocs.io/en/l... .

Thank you,
Adrian Vladu

edit flag offensive delete link more

Comments

Hi, I try but it's not working. this is unattend log: https://pastebin.com/dZdjBizb this is config file: https://pastebin.com/V01FDskh this is user-data, meta-data, network config: https://pastebin.com/6DXfBRuF thank you for helping, Mojtaba Hosseinalinejad

mojtabahosseinalinejad gravatar imagemojtabahosseinalinejad ( 2021-11-16 07:03:37 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2021-11-14 13:24:06 +0200

Seen: 36 times

Last updated: Nov 15