New Question
0

Issues with meta, activate, serial and hdd-extend

asked 2015-04-01 22:11:44 +0300

jetole gravatar image

updated 2015-04-01 23:19:31 +0300

I'm currently in the process of creating a instance locally on kvm-qemu before uploading to OpenStack. The instance is Windows Server 2008R2 x86_64. The requirements are fairly simple so far and they are:

  • Does not need to pull data from meta data server.
  • Does not need to create users or set passwords.
  • Does need to activate the instance with Microsoft.
  • Does need to expand the partitions and file system to fill the disk size.

Right now, the logs show that we are querying the meta data server even though I have not specified any configuration options for it to do so. The instance is not being activated with Microsoft but it does have a valid MAK key (volume licensing) installed and if I click on activate, it activates fine. The partitions and file systems are not being extended to the size of the disks. The serial port does not seem to be displaying any data. I have verified that the "Cloud Initialization Service" is running.

The contents of "C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-init\conf\cloudbase-init.conf" are:

[DEFAULT]
config_drive_raw_hhd=true
config_drive_cdrom=true
config_drive_vfat=true
bsdtar_path=C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\bin\bsdtar.exe
mtools_path=C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\bin\
verbose=true
debug=true
logdir=C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\log\
logfile=cloudbase-init.log
default_log_levels=comtypes=INFO,suds=INFO,iso8601=WARN
logging_serial_port_settings=COM1,115200,N,8
mtu_use_dhcp_config=true
ntp_use_dhcp_config=true
local_scripts_path=C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\LocalScripts\
plugins=cloudbaseinit.plugins.windows.sethostname.SetHostNamePlugin,cloudbaseinit.plugins.windows.networkconfig.NetworkConfigPlugin,cloudbaseinit.plugins.windows.extendvolumes.ExtendVolumesPlugin,cloudbaseinit.plugins.windows.licensing.WindowsLicensingPlugin,cloudbaseinit.plugins.windows.mtu.MTUPlugin
activate_windows=true
network_adapter=
mtu_use_dhcp_config=true

The contents of "C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-init\log\cloudbase-init.log" are:

The contents of "C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-init\log\cloudbase-init.log" are:
2015-04-01 14:22:54.907 1644 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.osutils.windows.WindowsUtils' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-04-01 14:22:56.622 1644 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.metadata.services.httpservice.HttpService' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-04-01 14:22:56.763 1644 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.osutils.windows.WindowsUtils' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-04-01 14:22:56.779 1644 DEBUG cloudbaseinit.utils.network [-] Testing url: http://169.254.169.254/ check_url C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\network.py:31

There is no cloudbase-init-unattend.log.

UPDATE:

I don't know if cloudbase-init-unattend.conf should have been used. These systems are sysprep'd with the generalize / OOBE. I'm pasting the cloudbase-init-unattend here as well but it's the default.

[DEFAULT]
username=Admin
groups=Administrators
inject_user_password=false
config_drive_raw_hhd=true
config_drive_cdrom=true
config_drive_vfat=true
bsdtar_path=C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\bin\bsdtar.exe ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2015-04-02 13:13:35 +0300

ader1990 gravatar image

Hello,

First of all, with the latest changes in cloudbase-init code, some plugins have been moved to a new namespace. Make sure you have the appropriate plugins definition in your cloudbase-init.conf file. Latest code can be found here: https://github.com/stackforge/cloudba... . For example:

  • cloudbaseinit.plugins.windows.sethostname.SetHostNamePlugin -> cloudbaseinit.plugins.common.sethostname.SetHostNamePlugin

Secondly, I would suggest to use the cloudbase-init installer Sysprep option(without checking the automated Shutdown option), as it takes care of running cloudbase-init unattend. After you run sysprep, update the cloudbase-init.conf and cloudbase-init-unattend.conf according to your needs and shutdown the vm.

Hope it helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-04-01 22:11:44 +0300

Seen: 403 times

Last updated: Apr 02 '15