Windows 2012 Network Adapters not discovered

asked 2015-12-22 22:30:26 +0300

markoates gravatar image

updated 2015-12-22 22:32:40 +0300


I'm having an issue on W2K12 where the cloudinit service won't discover networks on the W2K12 server when using the service's configured user via the default installation method..

2015-12-22 02:15:54.314 3068 DEBUG cloudbaseinit.utils.debiface [-] Found new interface: {'name': 'eth0', 'dnsnameservers': [''], 'netmask': '', 'netmask6': None, 'mac': None, 'broadcast': None, 'gateway': '', 'address': '', 'gateway6': None, 'address6': None} _add_nic c:\program files\cloudbase solutions\cloudbase-init\python\lib\site-packages\cloudbaseinit\utils\
2015-12-22 02:15:54.376 3068 ERROR cloudbaseinit.init [-] plugin 'NetworkConfigPlugin' failed with error 'no network adapters available'
2015-12-22 02:15:54.376 3068 ERROR cloudbaseinit.init [-] no network adapters available
edit retag flag offensive close merge delete


Running the WMI query manually (as administrator): PS C:\Users\Administrator> $query = "SELECT * FROM Win32_NetworkAdapter WHERE AdapterTypeId = 0 AND MACAddress IS NOT NULL"

markoates gravatar imagemarkoates ( 2015-12-22 22:37:36 +0300 )edit

PS C:\Users\Administrator> Get-WmiObject -Query $query ServiceName : E1G60 MACAddress : 00:00:56:A1:57:20 AdapterType : Ethernet 802.3 DeviceID : 13 Name : Intel(R) PRO/1000 MT Network Connection NetworkAddresses : Speed : 1000000000

markoates gravatar imagemarkoates ( 2015-12-22 22:37:46 +0300 )edit

Leading me to believe the service can't enumerate the NIC. I modified the service to run as `local system` instead of `.\cloudinit`, cleared the registry of the prevent it from re-running values, and re-started the service. This time it worked...

markoates gravatar imagemarkoates ( 2015-12-22 22:38:15 +0300 )edit

2015-12-22 05:55:47.287 3340 DEBUG cloudbaseinit.utils.debiface [-] Found new interface: {'mac': None, 'gateway': '', 'netmask6': None, 'netmask': '', 'address': '', 'name': 'eth0', 'address6': None, 'dnsnameservers': [''], 'broadcast': None, 'gateway6': None}

markoates gravatar imagemarkoates ( 2015-12-22 22:38:23 +0300 )edit

Please help me find a way of accomplishing this without needing to change who the service runs as... Thanks, Mark

markoates gravatar imagemarkoates ( 2015-12-22 22:38:30 +0300 )edit

P.S. - Sorry for the comment trail, but the post itself wouldn't let me do this all as one block, it kept timing out.

markoates gravatar imagemarkoates ( 2015-12-22 22:39:00 +0300 )edit

I'm continuing to investigate... my hypothesis of permissions seems off... if I set WMI perms or the service user it fails on first boot, but succeeds on subsequent runs. I think it might have to do with my template and the NIC not being discovered in device manager, so it's a timing issue...

markoates gravatar imagemarkoates ( 2015-12-23 20:10:23 +0300 )edit