New Question
0

Clouldbase with VIO and no password Windows vm issue.

asked 2016-02-07 23:42:46 +0200

kingtut101 gravatar image

I have been using Vmware Intergrated Openstack for a month or so now and I seem to have some issues with the clouldbase-init working for me. Now , I have the custom YAML file set for the customization = false so it doesn't use the customization wizard. I have the cloundbase-ini conf file exactly as it is out of the box.

I am trying to spin up a windows machine using the Openstack menu off a good known windows image in glance, and using a public/private key pair. Clouldbase-init is set to injectuserpassword=true. After the VM is booted , retrieving the password from the Horizon menu shows me the public key that is used , but the below area where you copy/past the public key is greyed out saying I did not set the password for the admin account. Did I miss something in the config ?

Thanks

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2016-02-08 13:32:47 +0200

alexpilotti gravatar image

"injectuserpassword" can be used to inject the password only when available in the metadata, which in OpenStack's case happens when ConfigDrive is used as the metadata provider, but not with HTTP metadata.

Alternatively to have it working with HTTP, it can be also passed in the form of custom metadata using the nova boot command:

nova boot ... --meta admin_pass=xxxxxx

Injecting the password is anyway not recommended, as it's included in clear text in the metadata. The preferred solution consists in using nova get password to retrieve the randomly generated password encrypted with the user's keypair:

nova get-password <instance> <path_to_SSH_private_key>
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-02-07 23:42:46 +0200

Seen: 82 times

Last updated: Feb 08 '16