New Question
0

Windows2016 image with cloudbase-init

asked 2021-03-29 09:30:24 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi experts, We are trying to use cloudbase-init with VMWARE and having issue where netwrok adapters get disabled/disconnected when we add additional plugins in cloudbase-init-unattended.conf and/or cloudbas-init.conf files. Please note that we are using this first time and the image/template works fine with default plugins which I don't know if being used OR not, since I don't know how to get this info. Here is summary of our test setup

1) VMWARE base Windows2016 server image with some hardening as per company policy 2) cloudbase-init installation as per https://blogs.vmware.com/management/2... 3) Then used this template in build via Red Hat Satellite Server 6.7

What we are finding that without custom plugins all works fine apart form DNS suffix is empty, which I imagine can be fixed using the cmdrun and/or userdata script. But issue is when we enable these plugins in the cloudbase-init-unattended.conf and cloudbase-init.conf files , the network adapters appear as disconnected. We are not sure whether we are lacking knowledge of using these plugins OR we are stuffing up something else without even realizing. Any pointers shall be greatly appreciated.

Kind Regards, Zia-ul-Hassan

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2021-03-29 13:32:26 +0300

avladu gravatar image

Hello,

Can you share the before (the working configuration files) and after (non-working) cloudbase-init configuration files?

Thank you.

edit flag offensive delete link more
0

answered 2021-03-31 23:46:09 +0300

zhassan gravatar image

updated 2021-04-01 21:29:50 +0300

avladu gravatar image

This configuration that works, with just default plugins and metadata service

[DEFAULT]
username=Administrator

groups=Administrators

inject_user_password=true

config_drive_raw_hhd=true

config_drive_cdrom=true

config_drive_vfat=true

bsdtar_path=C:\Program Files\Cloudbase Solutions\Cloudbase-Init\bin\bsdtar.exe

mtools_path=C:\Program Files\Cloudbase Solutions\Cloudbase-Init\bin\

verbose=true

debug=true

logdir=C:\Program Files\Cloudbase Solutions\Cloudbase-Init\log\

logfile=cloudbase-init-unattend.log

default_log_levels=comtypes=INFO,suds=INFO,iso8601=WARN,requests=WARN

logging_serial_port_settings=

mtu_use_dhcp_config=true

ntp_use_dhcp_config=true

local_scripts_path=C:\Program Files\Cloudbase Solutions\Cloudbase-Init\LocalScripts\

check_latest_version=false

metadata_services=cloudbaseinit.metadata.services.ovfservice.OvfService

plugins=cloudbaseinit.plugins.common.mtu.MTUPlugin,cloudbaseinit.plugins.common.sethostname.SetHostNamePlugin,cloudbaseinit.plugins.windows.extendvolumes.ExtendVolumesPlugin

allow_reboot=false

stop_service_on_exit=false

This configuration doesn't work; network adapters remain disabled after the host/vm get provisioned by VMWare

[DEFAULT]

username=Administrator

groups=Administrators

inject_user_password=true

config_drive_raw_hhd=true

config_drive_cdrom=true

config_drive_vfat=true

bsdtar_path=C:\Program Files\Cloudbase Solutions\Cloudbase-Init\bin\bsdtar.exe

mtools_path=C:\Program Files\Cloudbase Solutions\Cloudbase-Init\bin\

verbose=true

debug=true

logdir=C:\Program Files\Cloudbase Solutions\Cloudbase-Init\log\

logfile=cloudbase-init-unattend.log

default_log_levels=comtypes=INFO,suds=INFO,iso8601=WARN,requests=WARN

logging_serial_port_settings=

mtu_use_dhcp_config=true

ntp_use_dhcp_config=true

local_scripts_path=C:\Program Files\Cloudbase Solutions\Cloudbase-Init\LocalScripts\

check_latest_version=false

metadata_services=cloudbaseinit.metadata.services.base.EmptyMetadataService

plugins=plugins=cloudbaseinit.plugins.windows.extendvolumes.ExtendVolumesPlugin,cloudbaseinit.plugins.
common.networkconfig.NetworkConfigPlugin,cloudbaseinit.plugins.common.sethostname.SetHostNameP
lugin,cloudbaseinit.plugins.common.setuserpassword.SetUserPasswordPlugin,cloudbaseinit.plugin
s.common.localscripts.LocalScriptsPlugin,cloudbaseinit.plugins.common.userdata.UserDataPlugin

allow_reboot=false

stop_service_on_exit=false

userdata_save_path=C:\Program Files\Cloudbase Solutions\Cloud-Init\log\userdata.txt

I hope this provides you the info.

Regards, Zia-ul-Hassan

edit flag offensive delete link more

Comments

The non-working configuration has this line: metadata_services=cloudbaseinit.metadata.services.base.EmptyMetadataService This line instructs cloudbase-init to use EmptyMetadataService, which does not use any metadata and that s why it does not work.

avladu gravatar imageavladu ( 2021-04-01 21:31:53 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2021-03-29 09:30:24 +0300

Seen: 310 times

Last updated: Apr 01