New Question

Revision history [back]

click to hide/show revision 1
initial version

Password is not set correctly


I've build my own Windows Image (Windows 2012 R2 Standard) by following this guide:

I am creating my instances with metadata => {admin_pass => "MySpecialPassword123!@"}. My generated passwords are following the Windows password complexity requirements:

I want to use my own password passed by the Metadata Service of OpenStack.

I've set the following attributes in both configs:

  • C:\Program Files\Cloudbase Solutions\Cloudbase-Init\conf\cloudbase-init.conf
  • C:\Program Files\Cloudbase Solutions\Cloudbase-Init\conf\cloudbase-init-unattend.conf

The OpenStack Instance Log shows up also "Set password for existing user Administrator". Looks fine but I can't login with my metadata password and Windows still tells me to change my password after the login. I don't know why this happens because firstlogonbehaviour is set to "no".

As quick-fix I am setting my passwords via powershell by myself. But that solution is really dirty and I would recommend to use the build-in function.

Does anyone know what the problem can be?

Thank you!

Regards, Alexander