New Question

Revision history [back]

click to hide/show revision 1
initial version

Resizing Gen2 Guest EFI


We are currently running an hyperv cluster with storage spaces direct based on 3x nodes. They are using the nova-ocata computer driver from cloudbase. We have OpenStack Ocata deployed as a single node / single VM through RDO. These nodes are configured so that it uses differential disks when creating instances. Images being used within glance contain the Gen2 attribute.

So far, instances are running just fine.

We've been trying to resize one of our CentOS7 guest (still gen2); we applied a new flavor with a new disk size (100GB -vs- 50GB) and initiated the resize process (which took quiet awhile to complete, but that is fine).

What we stumbled across though is that once the resize process has completed, the instance wasn't able to boot due to missing EFI.

We tried several things within the guest itself but to no avail. What seemed to fix the issue was to manually re-create a new differential disk from which the main disk was still the same has previously used. Booted once into that new disk and got the shim.efi (re)installed. Then, we simply re-attached the resized differential disk and was able to boot the instance properly.

Is there any way to avoid this when doing a resize of a Gen2 instance ?

Please let me know if you guys need further information.

Thanks! -Luc