New Question

Revision history [back]

click to hide/show revision 1
initial version

V-Magine Error: Could not find data item CONFIG_USE_SUBNETS


I am running the V-Magine on a Huper-V 2012R2 server with public DHCP network in the range.

When I run the V-Magine tool I fill in all the values and during the setup it hangs on the install of the puppet manifests. The log file shows exactly the same message.

I saw exactly the same error on this video but in his case the setup finishes. What to do?

Thanks for a reply.


Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run:
Error: Could not find data item CONFIG
USESUBNETS in any Hiera data file and no default supplied at /var/tmp/packstack/3db99ddabcfe4ebd b9efd1b5da79ff37/manifests/ on node rdo.cloudbase
You will find full trace in log /var/tmp/packstack/20151126-115905-VclZdy/manifests/
Please check log file /var/tmp/packstack/20151126-115905-VclZdy/openstack-setup.log for more information
Additional information:
* Warning: NetworkManager is active on, OpenStack networking currently does not work on systems that have the Network Manager service enabled.
* File /root/keystonerc
admin has been created on OpenStack client host To use the command line tools you need to source the file.
* To access the OpenStack Dashboard browse to .
Please, find your login credentials stored in the keystonerc_admin in your home directory.
* To use Nagios, browse to username: nagiosadmin, password: 916703769a004244