New Question

Alexander Birkner's profile - activity

2016-10-21 22:26:48 +0200 received badge  Famous Question (source)
2016-10-20 19:08:01 +0200 received badge  Notable Question (source)
2016-10-20 15:11:08 +0200 received badge  Popular Question (source)
2016-10-18 12:50:59 +0200 asked a question Password is not set correctly

Hello,

I've build my own Windows Image (Windows 2012 R2 Standard) by following this guide: http://docs.openstack.org/image-guide...

I am creating my instances with metadata => {admin_pass => "MySpecialPassword123!@"}. My generated passwords are following the Windows password complexity requirements: https://technet.microsoft.com/en-us/l...

I want to use my own password passed by the Metadata Service of OpenStack.

I've set the following attributes in both configs:

  • C:\Program Files\Cloudbase Solutions\Cloudbase-Init\conf\cloudbase-init.conf
  • C:\Program Files\Cloudbase Solutions\Cloudbase-Init\conf\cloudbase-init-unattend.conf
inject_user_password=true
first_logon_behaviour=no
username=Administrator

The OpenStack Instance Log shows up also "Set password for existing user Administrator". Looks fine but I can't login with my metadata password and Windows still tells me to change my password after the login. I don't know why this happens because firstlogonbehaviour is set to "no".

As quick-fix I am setting my passwords via powershell by myself. But that solution is really dirty and I would recommend to use the build-in function.

Does anyone know what the problem can be?

Thank you!

Regards, Alexander