New Question

HD's profile - activity

2017-09-11 15:23:33 +0200 received badge  Taxonomist
2015-09-18 13:32:45 +0200 received badge  Famous Question (source)
2015-08-08 19:34:20 +0200 received badge  Notable Question (source)
2015-08-05 17:02:24 +0200 commented answer Windows 10 Hostname not set correctly

I have got it working but not sure if its the right change. Check http://paste.openstack.org/show/408335/

2015-08-04 19:12:20 +0200 received badge  Popular Question (source)
2015-08-03 04:57:39 +0200 commented answer Windows 10 Hostname not set correctly

I deleted the original machine. I created a new one with name hdtest1. Here is the meta_data.json {"random_seed": "cBjezGwAMbexbEAtuLZoF6WW5QGOYb1fIRlR4Da9JdoBw06+3/g+LnqGqEjUSRSrnLbNcooXsEVdwK5054s23cm/HefGyPjgHlbt17cC1A1AGptacYU0WKGZYg1ZpiMbKM6iT4MBDCL8RnYXabq7P+kOpFTYqQ5qHDKo5aSQgQ4sYjNpRYAVMUq20xOT5nYy69XZU2sgv7cICdLjSCzud2m2YGTgSdSZh9Y4HtH6EKLFVQbgHr+HBi78LFCfe9HnJa6jBECUyFxq/lctpBlqb3dksQmSC53yIQrTMGnNeBUuDix+3PULlY2PORZc+fnm497bt+sr55gyU0N6OZqf+u2xc8kOokc+RjHaoAsbft0hMyrR3nkn0pTsMXpbzq4KPb3jVqMWJ2eV13kFuWWPN9aTkRKYygHPao4b1rVYuHQv+I9Wy8kGHJ1TnELRlpQBjm/0pOnwLNTWRofdM9n8Zxxnwo5Ws2P1+tbYkadjTqjBIfl8R04ZLkvbzzoHOo9rQUW+3QImlaaS5ic3eAOEVsXCbtxJhLgfqNydbisFIPt8MHA23PlhwCoOX6wgwNX1EQOEOZrihGnYalZU/pocuRpAm5RQ7NLVsp4qjatSuamgmDdHZ5+kd+QdMcYCTBOdDC9aCmaqqg4tWBeMbNC0IsciKctKVYh2x9MJiFWF4og=", "uuid": "37c78fa7-033a-4244-8edc-6984c40516a7", "availability_zone": "Production", "hostname": "hdtest1", "launch_index": 0, "name": "hdtest1"}

2015-08-02 17:03:46 +0200 answered a question Windows 10 Hostname not set correctly

The URL you gave is not present on my setup. However, I can see the hostname correctly passed via this URL

PS C:\Users\Administrator> Invoke-WebRequest http://169.254.169.254/latest/meta-data/hostname -UseBasicParsing


StatusCode        : 200
StatusDescription : OK
Content           : hdent4
RawContent        : HTTP/1.1 200 OK
                    Content-Length: 6
                    Content-Type: text/html; charset=UTF-8
                    Date: Sun, 02 Aug 2015 13:27:55 GMT

                    hdent4
Forms             :
Headers           : {[Content-Length, 6], [Content-Type, text/html; charset=UTF-8], [Date, Sun, 02 Aug 2015 13:27:55
                    GMT]}
Images            : {}
InputFields       : {}
Links             : {}
ParsedHtml        :
RawContentLength  : 6

Hostname is set via the Metadata. I don't think Init Script has anything to do with it. I get the same results even when I don;t pass any inti script

2015-08-01 17:23:53 +0200 answered a question Windows Server 2012 R2 cannot open websites

You can try to switch off IE Security http://blog.blksthl.com/2012/11/28/ho...

If that doesn't work ....

Can you Ping to anything apart from bing.com?

Open command prompt and run ping 8.8.8.8

Does this get correct reply? or does it timeout ?

Can you try installing Firefox and browsing using Firefox? Does that work?

2015-08-01 17:17:21 +0200 asked a question Windows 10 Hostname not set correctly

Hi,

I install latest stable build of Cloudbase for Windows x64 on Windows 10 Enterprise N edition. Syspreped it created an image.

Deployed the image and passed an init script.

The hostname is not getting set correctly. However, I do see that Cloud Init is starting on boot and getting the correct hostname from Metadata service.

Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\Users\Administrator>hostname
DESKTOP-ROSFNJ5

The Cloud init log file get the correct metadata from 169.254.169.254

2015-08-01 12:09:44.036 1888 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.osutils.windows.WindowsUtils' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-08-01 12:09:48.599 1888 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.metadata.services.configdrive.ConfigDriveService' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-08-01 12:09:49.006 1888 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.metadata.services.osconfigdrive.windows.WindowsConfigDriveManager' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-08-01 12:09:49.209 1888 DEBUG cloudbaseinit.metadata.services.osconfigdrive.windows [-] Looking for Config Drive in VFAT filesystems get_config_drive_files C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\metadata\services\osconfigdrive\windows.py:162
2015-08-01 12:09:49.209 1888 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.osutils.windows.WindowsUtils' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-08-01 12:09:50.161 1888 WARNING cloudbaseinit.utils.windows.vfat [-] Could not retrieve label for VFAT drive path '\\\\.\\PHYSICALDRIVE0'
2015-08-01 12:09:50.161 1888 WARNING cloudbaseinit.utils.windows.vfat [-] mlabel failed with error "init :: sector size (190) not a small power of two\r\nCannot initialize '::'\r\nC:\\Program Files (x86)\\Cloudbase Solutions\\Cloudbase-Init\\bin\\mlabel: Cannot initialize drive\r\n"
2015-08-01 12:09:50.161 1888 DEBUG cloudbaseinit.metadata.services.osconfigdrive.windows [-] Looking for Config Drive in raw HDDs get_config_drive_files C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\metadata\services\osconfigdrive\windows.py:166
2015-08-01 12:09:50.177 1888 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.osutils.windows.WindowsUtils' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-08-01 12:09:50.177 1888 DEBUG cloudbaseinit.metadata.services.osconfigdrive.windows [-] Looking for Config Drive in cdrom drives get_config_drive_files C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\metadata\services\osconfigdrive\windows.py:171
2015-08-01 12:09:50.177 1888 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.osutils.windows.WindowsUtils' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-08-01 12:09:50.177 1888 DEBUG cloudbaseinit.utils.classloader [-] Loading class 'cloudbaseinit.metadata.services.httpservice.HttpService' load_class C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\lib\site-packages\cloudbaseinit\utils\classloader.py:26
2015-08-01 12:09:50.272 1888 DEBUG cloudbaseinit.utils.classloader ...
(more)
2015-02-27 16:15:23 +0200 received badge  Famous Question (source)
2014-12-16 03:13:57 +0200 received badge  Notable Question (source)
2014-12-13 09:05:15 +0200 commented question Password chaneg dialog before first logon

Thanks a ton! It all works as it is meant to be :)

2014-12-12 16:25:14 +0200 commented answer Password chaneg dialog before first logon

try to run "$ENV:SystemRoot\System32\Sysprep\Sysprep.exe" /generalize/oobe /shutdown again, that should work and get your environment working as expected. So u want me to pass the /unattend:filepath param to sysprep?

2014-12-11 18:09:04 +0200 received badge  Popular Question (source)
2014-12-11 16:02:19 +0200 commented answer Password chaneg dialog before first logon

There is nothing in the user_data script. The answerfile is the autounattend.xml that is passed to sysprep before the final shutdown of the vm which will be used as an image to create instances

2014-12-11 16:00:43 +0200 answered a question Password chaneg dialog before first logon

Some snippet

CloudBase init is installed using

$serialPortName = @(Get-WmiObject Win32_SerialPort)[0].DeviceId

$p = Start-Process -Wait -PassThru -FilePath msiexec -ArgumentList "/i PATHTOMSI /qn /l*v PATHTOMSILOG LOGGINGSERIALPORTNAME=$serialPortName"

Next, I run C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\bin\SetSetupComplete.cmd

Then I run sysprep & "$ENV:SystemRoot\System32\Sysprep\Sysprep.exe" /generalize/oobe /shutdown/unattend:"$LocalUnattendFile"

I am not able to attach the $LocalUnattendFile

Its a standard autounattend.xml with oobe and specialize pass <unattend xmlns="urn:schemas-microsoft-com:unattend"> <settings pass="generalize"> <component name="Microsoft-Windows-PnpSysprep" processorarchitecture="amd64" publickeytoken="31bf3856ad364e35" language="neutral" versionscope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <persistalldeviceinstalls>true</persistalldeviceinstalls> </component> </settings> <settings pass="oobeSystem"> <component name="Microsoft-Windows-Shell-Setup" processorarchitecture="amd64" publickeytoken="31bf3856ad364e35" language="neutral" versionscope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"> <oobe> <hideeulapage>true</hideeulapage> <networklocation>Work</networklocation> <protectyourpc>1</protectyourpc> <skipmachineoobe>true</skipmachineoobe> <skipuseroobe>true</skipuseroobe> </oobe> <useraccounts> <administratorpassword> <value>Pa55word$</value> <plaintext>true</plaintext> </administratorpassword> </useraccounts> <autologon> <password> <value>Pa55word$</value> <plaintext>true</plaintext> </password> <enabled>true</enabled> <logoncount>1</logoncount> <username>Administrator</username> </autologon> </component> </settings> <settings pass="specialize"> <component name="Microsoft-Windows-Deployment" processorarchitecture="amd64" publickeytoken="31bf3856ad364e35" language="neutral" versionscope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <runsynchronous> <runsynchronouscommand wcm:action="add"> <order>1</order> <path>powershell -NoLogo -Command "Set-ExecutionPolicy Unrestricted -force"</path> <description>Set-ExecutionPolicy to unrestricted</description> </runsynchronouscommand> <runsynchronouscommand wcm:action="add"> <order>2</order> <path>"C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\Python27\Scripts\cloudbase-init.exe" --config-file "C:\Program Files (x86)\Cloudbase Solutions\Cloudbase-Init\conf\cloudbase-init-unattend.conf"</path> <description>Run Cloudbase-Init to set the hostname</description> <willreboot>Always</willreboot> </runsynchronouscommand> </runsynchronous> </component> </settings> </unattend>

After syspreping, I copy the image to openstack and then try to create an instance. The oobe pass should set the administrator password. All this works with Cloud base init build of 15 Sep 2014. With the latest cloud-base msi, the machine boots up coreectly, but the Administrator doesn't get autologged on. Also, I see a message on colsole saying Administrator must change password. Once I change the password, everything works.

The gotcha is I want Administrator account to autologon.

2014-12-11 09:18:17 +0200 asked a question Password chaneg dialog before first logon

Hello,

With the latest build of cloudbase-init. i am gettting a prompt saying

Password must be changed at first logon

after the first boot. I have provided the AdministratorPassword in Answerfile. This problem doesn't occur for cloudbase-init build dated 15th Sep 2014. I moved to the latest build to get a fix for Administrator accounts issue on Spanish Windows OS. However the latest build has created this issue of Administrator not able to Autologon inspite of me using the same answerfile as before

-HD