New Question
0

Cannot launch instance on hyper-v compute node

asked 2016-12-19 18:27:38 +0300

safwene gravatar image

Hello, I'm trying to run a VM into hyper-v from the dashboard of openstack-mitaka, But it failed and i'm getting "PortBindingFailed: Binding failed for port , please check neutron logs for more information" - but Neutron log can't tell much about what the problem is. Thank's,

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
1

answered 2016-12-22 20:03:37 +0300

semka_mesilov gravatar image

Check your neutron server status and logs for any errors or python traces. Possibly you made something wrong because it seems neutron is not working properly if you can not retrieve objects in dashboard.

edit flag offensive delete link more
0

answered 2016-12-22 15:50:30 +0300

semka_mesilov gravatar image

Hi, what kind of networking do you use in Hyper-V compute nodes? Native hyper-v switch or OVS extension?

edit flag offensive delete link more

Comments

We are in the same team, so we use linuxbridge not OpenVswitch in openstack mitaka .. so we install cloud base for hyper-v mitaka version in windows server 2012 R2 ..when we open the nova-compute log file we have error "PortBinding:Failed: Binding failed port " Please help us

pazzo_marza gravatar imagepazzo_marza ( 2016-12-22 16:55:05 +0300 )edit

Well, you have Neutron server with linuxbridges, it's okay. How did you prepare compute nodes to connect to Neutron networks? Did you install hyperv neutron agent? Did you configure neutron mech driver on neutron server for hyperv networking?

semka_mesilov gravatar imagesemka_mesilov ( 2016-12-22 17:51:59 +0300 )edit

I install cloudbase mitaka for windows and i create a hyper-v virtual Ethernet adapter like th offical document in this link : http://docs.openstack.org/mitaka/config-reference/compute/hypervisor-hyper-v.html .. there' s another step i didnt do ?

pazzo_marza gravatar imagepazzo_marza ( 2016-12-22 18:07:41 +0300 )edit

After compute driver installation you need to configure you neutron server to work with native hyperv switch. Please look through this article: https://cloudbase.it/neutron-hyper-v-plugin/ You need to configure neutron ml2 plugin with hyperv mechanism driver.

semka_mesilov gravatar imagesemka_mesilov ( 2016-12-22 18:51:10 +0300 )edit

One we add hyperv on the mechanism driver ..so we can't acces to any composant in the dashboard "unable to retrive instance" .. have u a solution?

pazzo_marza gravatar imagepazzo_marza ( 2016-12-22 19:16:50 +0300 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools

1 follower

Stats

Asked: 2016-12-19 18:27:38 +0300

Seen: 290 times

Last updated: Dec 22 '16