Install v-magine fail "need more than 1 value to unpack"

asked 2016-11-10 00:26:02 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

At Hyper-V Server 2012R2 & Hyper-V Server 2016 have still errors: need more than 1 value to unpack

How to fix it - where to look for problems ?

v-magine log:

edit retag flag offensive close merge delete


Seems like config variables were not passed on. Please connect to the VM and see if there is a ssh key in ~/.ssh/ and if there is a in /etc/nova/nova.conf config file. This happens even after several retries?

danardelean gravatar imagedanardelean ( 2016-11-11 12:39:42 +0300 )edit

Tryed around 9 times on different machines with Hyper-V. In /root/.ssh/ is only authorized_keys file. The folder /etc/nova does not exist.

sztyrlic111 gravatar imagesztyrlic111 ( 2016-11-11 14:43:40 +0300 )edit

During the puppet run everything was OK? Can you please freeze the VM (pause in Hyper-V) right after the RDO puppet is done and look for the /etc/nova? That directory shoud be there right after the RDO finishes. Thank you.

danardelean gravatar imagedanardelean ( 2016-11-14 15:17:49 +0300 )edit

Pause VM is 3:24 or 7:13 from video ? Everytime when I logged over console to openstack-controller couldn't find /etc/nova directory. Last logs from console: -

sztyrlic111 gravatar imagesztyrlic111 ( 2016-11-15 11:04:50 +0300 )edit

Hi I'm Carsten, have the same problem (but tried it in Windows Server 2016 nested). Yes I know it stated Windows Server 2012 R2. Question what is the password of the openstack-controller? Cheers Carsten Rachfahl Hyper-V MVP

CRachfahl gravatar imageCRachfahl ( 2016-11-15 17:28:06 +0300 )edit

Hi Carsten, the password is the one that you provided during the initial configuration page in v-magine

alexpilotti gravatar imagealexpilotti ( 2016-11-15 17:44:50 +0300 )edit

So... Any news about this bug in installer ?

sztyrlic111 gravatar imagesztyrlic111 ( 2016-11-28 11:27:24 +0300 )edit

Today I've downloaded latest version from web and error gone (user password without ! and / \ . But got another errors:

sztyrlic111 gravatar imagesztyrlic111 ( 2016-12-04 12:07:11 +0300 )edit

When I rebooted vm got interesting errors:

sztyrlic111 gravatar imagesztyrlic111 ( 2016-12-04 12:17:46 +0300 )edit

How much memory did you assign to the RDO VM? Please also ensure to have DHCP on the network.

alexpilotti gravatar imagealexpilotti ( 2016-12-04 12:50:54 +0300 )edit

RDO VM got assigned by 3592 MB RAM. Whole hyper-v host have 8 GB RAM. Yes, DHCP assigned RDO VM one of IP Address which works well - during install I can login over SSH. After errors listed above all network interfaces gone except loppback.

sztyrlic111 gravatar imagesztyrlic111 ( 2016-12-04 16:40:02 +0300 )edit

3.5GB is a bit too tight, we recommend 6GB for the RDO VM. Can you increase the RAM to at least 4.5 GB and retry? If needed, it also possible to disable unnecessary OpenStack services (e.g. Heat) in to save memory.

alexpilotti gravatar imagealexpilotti ( 2016-12-04 16:58:14 +0300 )edit

Thanks for tip, Installed another Hyper-V with 20 GB of RAM and gave for openstack controller 12 GB. Anyway dashboard isnt fully usable (errors everytime) till reboot rdo controller. Thanks I'll test now...

sztyrlic111 gravatar imagesztyrlic111 ( 2016-12-04 23:36:39 +0300 )edit

cool, could you please add some details on what error did you get accessing the dashboard before rebooting the RDO controller?

alexpilotti gravatar imagealexpilotti ( 2016-12-04 23:46:14 +0300 )edit

Went sleep after reboot - but today morning started tests again and errors came back: . Horizon logs from /var/log/horizon/horizon.log

sztyrlic111 gravatar imagesztyrlic111 ( 2016-12-05 11:11:53 +0300 )edit

Can you please do a nova boot and a 'neutron net-list' from CLI? I want to see if this is an isolated issues with Horizon, something wrong with keystone, or the DB. Thanks.

danardelean gravatar imagedanardelean ( 2016-12-06 10:50:28 +0300 )edit

Here bash output: . Here listening services: . Here ifconfig .

sztyrlic111 gravatar imagesztyrlic111 ( 2016-12-06 11:10:41 +0300 )edit