Port Binding failed - windows 2016 Nested

asked 2017-02-15 05:21:29 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have tested the settings from my end and still getting any port binding failed error. I have added nanoserver VHD as glance image. Here is my configuration screenshot http://pasteboard.co/yb8VVajPa.gif OpenStack system information screenshot. http://pasteboard.co/yba53UddS.gif

I will explain my current setup: My host server is windows 2016 and I have created 2 VM. one VM is for OpenStack controller and open VM (nested) is for nova-compute.

I have created flat network in OpenStack. Here is the network port configuration screenshot. http://pasteboard.co/ybgX80iD7.gif

Also, I have only one network card and I'm testing this setup as POC. Also, I have attached the nova-compute log and configuration file.

Nova log : http://paste.openstack.org/raw/598770/ Nova config : http://paste.openstack.org/raw/598771/ neutronhypervagent config : http://paste.openstack.org/raw/598772/

I'm really not sure what need to be done from my end. Can you please help me on this?

Regards, Loges

edit retag flag offensive close merge delete


You mention "Nested" in the subject. Do you mean that you are running Hyper-V nested in another hypervisor?

alexpilotti gravatar imagealexpilotti ( 2017-02-15 12:01:29 +0300 )edit

Actually, I have added windows 2016 hypervisor VM using nested VM concept.

Logeswaran gravatar imageLogeswaran ( 2017-02-17 12:15:13 +0300 )edit

On what hypervisor? You need to make sure multiple MAC addresses can be assigned to the data Ethernet ports in the Hyper-V nodes.

alexpilotti gravatar imagealexpilotti ( 2017-02-17 12:28:20 +0300 )edit

I'm using windows 2016 hypervisor. For testing purpose, I'm using with one ethernet. Should I need to have more than one NIC for hypervisor

Logeswaran gravatar imageLogeswaran ( 2017-02-18 06:13:37 +0300 )edit

You need promiscuous mode for your vNics, without it won't work: https://cloudbase.it/hyper-v-promiscuous-mode/

alexpilotti gravatar imagealexpilotti ( 2017-02-19 16:53:13 +0300 )edit