New Question
0

PortBindingFailed: Binding failed for port

asked 2017-05-30 23:23:27 +0200

leuridan gravatar image

Hello!

I'm attempting to run a HyperV Nova compute node on an Openstack Newton cluster. After following configuration instructions, I seem to have hit a roadblock. Upon attempting to provision a server, I get the following:

PortBindingFailed: Binding failed for port aef809a5-44c8-4cdb-9032-b5c6b9ad78bf, please check neutron logs for more information.

Neutron logs on Hyper-V show nothing at all.

Controllers have been configured with hyper-v drivers, and vlan only tenant network mechanisms.

Any clues on how to track this down?

Cheers! -d

edit retag flag offensive close merge delete

Comments

I've been running into the same problem myself. Haven't figured it out yet. Try checking the logs in /var/log/neutron on your controller node and see if there is anything interesting going on there. Maybe update us here and post your logs.

awestin1 gravatar imageawestin1 ( 2017-06-05 22:17:17 +0200 )edit

Here is a link to my question which may help walk you through my process. https://ask.cloudbase.it/question/2255/no-ports-have-port_id-starting-with-network-adapter/

awestin1 gravatar imageawestin1 ( 2017-06-05 23:05:42 +0200 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2017-08-18 18:37:06 +0200

lpetrut gravatar image

Things to check: - do a "neutron service-list", ensuring that your neutron hyper-v agents are up - ensure that the hyperv ML2 plugin is enabled and installed on your neutron server - check the neutron server logs using that port id to get some more detailed information

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-05-30 23:23:27 +0200

Seen: 156 times

Last updated: Aug 18