New Question
0

windows 2016 -- The application-specific permission settings do not grant Local Activation permission

asked 2017-11-21 00:24:49 +0200

rainmanh gravatar image

Hi,

I am installing cloudbase-init using automation on a windows2016 image. While the whole process seems working all right, I just noticed the VM created out of the base image got the cloudba-se-init service in automatic and stopped. I also noticed the VM reboots once before it gets ready for use. (Note: as the final step for the image creation is to start the cloubase-init service)

This is what I have found in the event viewer:

Log Name: System Source:
Microsoft-Windows-DistributedCOM Date: 11/14/2017 6:34:45 AM Event ID:
10016 Task Category: None Level:
Error Keywords: Classic User:
VM-12631\cloudbase-init Computer:
windows-2016 Description: The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {D63B10C5-BB46-4990-A94F-E40B9D520160} and APPID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} to the user WINDOWS-2016\cloudbase-init SID (S-1-5-21-1198788790-4189821438-4104815276-1000) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool. Event Xml: <event <a="" href="http://xmlns="http://schemas.microsoft.com/win/2004/08/events/event%22">xmlns="http://schemas.microsoft.com/w...> <system> <provider eventsourcename="DCOM" guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" name="Microsoft-Windows-DistributedCOM"> <eventid qualifiers="0">10016</eventid> <version>0</version> <level>2</level> <task>0</task> <opcode>0</opcode> <keywords>0x8080000000000000</keywords> <timecreated systemtime="2017-11-14T14:34:45.407722200Z"> <eventrecordid>672</eventrecordid> <correlation> <execution processid="644" threadid="684"> <channel>System</channel> <computer>windows-2016</computer> <security userid="S-1-5-21-1198788790-4189821438-4104815276-1000"> </security></execution></correlation></timecreated></provider></system> <eventdata> <data name="param1">application-specific</data> <data name="param2">Local</data> <data name="param3">Activation</data> <data name="param4">{D63B10C5-BB46-4990-A94F-E40B9D520160}</data> <data name="param5">{9CA88EE3-ACB7-47C8-AFC4-AB702511C276}</data> <data name="param6">WINDOWS-2016</data> <data name="param7">cloudbase-init</data> <data name="param8">S-1-5-21-1198788790-4189821438-4104815276-1000</data> <data name="param9">LocalHost (Using LRPC)</data> <data name="param10">Unavailable</data> <data name="param11">Unavailable</data> </eventdata></event>
</eventdata> </event>

Any idea? I am failing to find a workaround on this and I would need some suggestions.

Many thanks

edit retag flag offensive close merge delete

Comments

I am currently running different sorts of installations. I have manually started the cloudbase-init service but after awhile it just dies and I see the event above. A bit on the lost right now .

rainmanh gravatar imagerainmanh ( 2017-11-21 10:35:25 +0200 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2017-11-22 16:38:49 +0200

avladu gravatar image

Hello,

Here is an automation tool that you can use to generate Windows images: https://github.com/cloudbase/windows-...

The tool encapsulates cloudbase-init installation step.

Thank you, Adrian Vladu

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-11-21 00:24:49 +0200

Seen: 23 times

Last updated: Nov 22