New Question
0

There isn't any interface in VM. VM interface doesn't assign in VLAN.

asked 2015-01-21 13:46:14 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello,

I installed openstack juno on separate server ( keystone, neutron, nova, mysql, rabbit, glance) and compute node with windows. I want use hypervisor hyper-v. I installed your solution for juno release.

I can run VM from console, VM is running, it is working, but there is not any network interface in VM. As I now, hyper-v supported only VLAN network for openstack, so my configuration file for neutron is:

cat ml2conf.ini |grep -v "^#" |grep -xv "" [ml2] typedrivers = local,flat,vlan tenantnetworktypes = vlan mechanismdrivers = openvswitch tenantnetworktypes = vlan mechanismdrivers = openvswitch, hyperv [ml2typeflat] flatnetworks = external [ml2typevlan] networkvlanranges = physnet1:1000:2999,physnet2 [ml2typegre] tunnelidranges = 1:1000 [ml2typevxlan] [securitygroup] enablesecuritygroup = True enableipset = True firewalldriver = neutron.agent.linux.iptablesfirewall.OVSHybridIptablesFirewallDriver [ovs] localip = $localip enabletunneling = True bridgemappings = external:br-ex [agent] tunnel_types = vlan

threre is conf on compute node:

[DEFAULT] verbose=true controlexchange=neutron policyfile=C:\Program Files (x86)\Cloudbase Solutions\OpenStack\Nova\etc\policy.json rpcbackend=neutron.openstack.common.rpc.implkombu rabbithost=$rabbithost rabbitport=5672 rabbituserid=guestn rabbitpassword=EIhUEUiq#who logdir=D:\OpenStack\Log\ logfile=neutron-hyperv-agent.log [AGENT] pollinginterval=2 physicalnetworkvswitchmappings=*:Intel(R) I350 Gigabit Network Connection - Virtual Switch enablemetricscollection=false [SECURITYGROUP] firewalldriver=neutron.plugins.hyperv.agent.securitygroupsdriver.HyperVSecurityGroupsDriver enablesecuritygroup=false

Neutron agent is connected to neutron server, and it works.

But, when I create VM, its network interface doesn't assigned in VLAN

Get-VMNetworkAdapterVlan

VMName VMNetworkAdapterName Mode VlanList instance-00000010 ef839214-0944-4f6c-b6b0-50f143efa1a5 Untagged

And virtual machine doesn't have any network interface. I tryied cirros, fedora and windows server r2.

What is wrong? How to fix network problems?

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2015-01-22 21:22:32 +0200

Claudiu Belu gravatar image

Hello, Hyper-V also supports flat networking, but that's not the point.

From what I can see, you have defined mechanism_drivers twice in your ml2conf.ini file.

If you run Get-VMNetworkAdapter, what does it specify at the SwitchName? If it is blank, it means the neutron agent on the compute node did not bind the instance's Network Adapter to the VSwitch properly. The neutron logs would be useful: C:\OpenStack\Logs\neutron-hyper-v-agent.log

Now, if the Instance Network Adapter did not bind properly, it could also mean that neutron server could not do the proper binding. You should check the status of the neutron port this way:

nova show your_instance # get the assigned IP

neutron port-list | grep THEASSIGNEDINSTANCE_IP # get the port ID

neutron port-show PORT_ID

Neutron should have properly binded this port, you should see the status ACTIVE, binding:viftype hyperv and binding:hostid yourhypervhost

If it isn't so, it means that neutron failed to bind the neutron port to the Hyper-V host, which will mean that neutron-hyperv-agent will fail to get the details necessary to connect your instance to the VSwitch( including VLAN).

Then, a few steps would be helpful, to know how to proceed further.

neutron agent-list # is the neutron-hyperv-agent alive?

Also, the logs for for q-agt would be helpful, if there are any warning / errors in binding the neutron port to Hyper-V.

Let me know if anything helped and please post any other information I asked for in this response, so we can figure it out together. :-)

Best regards, Claudiu Belu

edit flag offensive delete link more

Comments

I found that I created network incorrect, should be neutron net-create net1 --provider:network_type vlan --provider:physical_network physnet1 --provider:segmentation_id 1001 VMName VMNetworkAdapterName Mode VlanList ------ -------------------- ---- -------- instance-0000003d f173690f-88da-44c3-9757-eb7a31cf287c Access 1001

rawsik gravatar imagerawsik ( 2015-01-23 17:21:53 +0200 )edit

But IP still doesn't get from DHCP server. And network doesn't work. As I understood, from network node should be VLAN connection to. I look at flows: ovs-ofctl dump-flows br-ex NXST_FLOW reply (xid=0x4): cookie=0x0, duration=534.240s, table=0, n_packets=3, n_bytes=126, idle_age=450, priority=1 actions=NORMAL cookie=0x0, duration=533.665s, table=0, n_packets=6, n_bytes=252, idle_age=450, priority=2,in_port=15 actions=drop and there are not any VLAN connection.

rawsik gravatar imagerawsik ( 2015-01-23 17:23:51 +0200 )edit

I don't know what I did, but it start works. may be I restarted nova services or neutron services againg. Now I have flow - cookie=0x0, duration=72.266s, table=0, n_packets=7, n_bytes=634, idle_age=70, priority=4,in_port=15,dl_vlan=5 actions=mod_vlan_vid:1001,NORMAL So VLANs works.

rawsik gravatar imagerawsik ( 2015-01-23 17:50:17 +0200 )edit

thank you!

rawsik gravatar imagerawsik ( 2015-01-23 17:50:21 +0200 )edit

Nevermind - So, are you getting IP and everything? If so, I'm glad I've helped. :)

Claudiu Belu gravatar imageClaudiu Belu ( 2015-01-23 17:52:30 +0200 )edit
0

answered 2015-01-23 12:16:32 +0200

rawsik gravatar image

updated 2015-01-23 12:17:23 +0200

Thank you for your answer. Port is available now!

my configs: cat ml2conf.ini |grep -v "^#" |grep -xv "" [ml2] tenantnetworktypes = vlan typedrivers = local,flat,vlan,gre,vxlan mechanismdrivers = openvswitch,hyperv [ml2typeflat] flatnetworks = br-ex [ml2typevlan] [ml2typegre] [ml2typevxlan] [securitygroup] [ovs] localip = 5.196.144.158 bridgemappings = physnet1:br-ex [agent]

Configuration file on hyper-v compute node wasn't changed. When I create VM, port is avaialble.

neutron port-show bd0eafd0-7516-4021-a50d-c6e5ea7d7ce9 +-----------------------+---------------------------------------------------------------------------------------+ | Field | Value | +-----------------------+---------------------------------------------------------------------------------------+ | adminstateup | True | | allowedaddresspairs | | | binding:hostid | mycomputehostid | | binding:profile | {} | | binding:vifdetails | {"portfilter": false} | | binding:viftype | hyperv | | binding:vnictype | normal | | deviceid | e01b1953-65f7-4eb3-963a-1b3ac80f914c | | deviceowner | compute:None | | extradhcpopts | | | fixedips | {"subnetid": "772aff82-2d72-4c94-b206-1a77ce5eefb7", "ipaddress": "myipaddress"} | | id | bd0eafd0-7516-4021-a50d-c6e5ea7d7ce9 | | macaddress | Mymac | | name | port129 | | networkid | 24b44a3f-0ed8-4186-9da9-be01e5a5d3eb | | securitygroups | 736bdd8e-2625-4953-9f5c-148346494625 | | status | ACTIVE | | tenantid | 24c79185ddcf422895b300b18fd3937d

My VM with windows server has one active port, which mac which i assigned. But NIC doesn't assign IP address.

PS C:\Windows\system32> Get-VMNetworkAdapterVLAN

VMName VMNetworkAdapterName Mode VlanList ------ -------------------- ---- -------- neutron-bridge Untagged instance-0000002d bd0eafd0-7516-4021-a50d-c6e5ea7d7ce9 Untagged

I have one bridge "neutron-bridge" which was created during installtion. And one interface for new VM. There are not any interface in tagged mode, as I understood it should be tagged.

There is one error in neutron log file:

015-01-23 12:03:03.086 2032 ERROR neutron.plugins.hyperv.agent.hypervneutronagent [req-f4227101-d864-4aa1-a8a7-dd034992d01f None] Error in agent event loop: HyperVException: Job failed with error 32775 2015-01-23 12:03:03.086 2032 TRACE neutron.plugins.hyperv.agent.hypervneutronagent Traceback (most recent call last): 2015-01-23 12:03:03.086 2032 TRACE neutron.plugins.hyperv.agent.hypervneutronagent File "C:\Program Files (x86)\Cloudbase Solutions\OpenStack\Nova\Python27\lib\site-packages\neutron\plugins\hyperv\agent\hypervneutronagent.py", line 448, in daemonloop 2015-01-23 12:03:03.086 2032 TRACE neutron.plugins.hyperv.agent.hypervneutronagent sync = self.processnetworkports(portinfo) 2015-01-23 12:03:03.086 2032 TRACE neutron.plugins.hyperv.agent.hypervneutronagent File "C:\Program Files (x86)\Cloudbase Solutions\OpenStack\Nova\Python27\lib\site-packages\neutron\plugins\hyperv\agent\hypervneutronagent.py", line 424, in _processnetworkports 2015-01-23 12:03:03.086 2032 TRACE neutron.plugins.hyperv.agent.hypervneutronagent resynca = self.treatdevicesadded(portinfo['added']) 2015-01-23 12:03:03.086 2032 TRACE neutron.plugins.hyperv.agent.hypervneutronagent File "C:\Program Files (x86)\Cloudbase Solutions\OpenStack\Nova\Python27\lib\site-packages\neutron\plugins\hyperv\agent\hypervneutronagent.py", line 387, in treatdevicesadded 2015-01-23 12:03:03.086 2032 TRACE neutron.plugins.hyperv.agent.hypervneutronagent devicedetails['adminstateup']) 2015-01-23 12:03:03.086 2032 TRACE neutron.plugins.hyperv.agent.hypervneutronagent File "C:\Program Files (x86)\Cloudbase Solutions\OpenStack\Nova\Python27\lib\site-packages\neutron\plugins\hyperv\agent\hypervneutronagent.py", line 355, in treatvifport 2015-01-23 12:03:03.086 ... (more)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-01-21 13:46:14 +0200

Seen: 1,008 times

Last updated: Jan 23 '15