New Question
0

FreeRDP Pike/Keystone v3 compatibility/errors

asked 2018-04-11 22:12:32 +0200

jwilson23 gravatar image

I can't get FreeRDP to work against a Pike installation of Keystone. I have tried the main and beta downloads. In the client there is a brief popup 'Could not connect to Websockets gateway' and a permanent 'This instance seems not to be working'. Looking in the system event log shows WSGate had a OpenStack token authentication failure.

The v2.0 API is deprecated (and wouldn't work) so I configured to use v3.

Out of the box the installer misses creating the 'keystoneversion = ' line for the configuration so it doesn't work properly; WSGate gives a message 'OpenStack token authentication failed: Not Found' which seems to be due to the request being malformed.

Adding 'keystoneversion = v3' manually into the configuration changes the error but doesn't fix the problem; an error is generated by WSGate 'OpenStack token authentication failed: Bad Request', and from Keystone 'SchemaValidationError: Invalid input for field scope/project: id or name must be present.' which again suggests a malformed request.

Is a newer version of the installer and application available? The beta appears to be trailing the most recent GitHub master commits which seem to relate to this area.

Also what is the best way to view the debugging output from WSGate? The event log messages don't show anything extra when debug=True (and are a bit broken anyway) and using Dbgview doesn't show anything obvious.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
0

answered 2018-04-12 14:28:31 +0200

alexpilotti gravatar image

Hi, yes, both Keystone V2 and V3 are supported

edit flag offensive delete link more

Comments

Out of the box though it doesn't work. * The keystoneversion = line isn't generated in the configuration by the installer. * The configuration of tenantname = vs. projectname = isn't resolved. An undocumented edit is required to change the generated 'tenantname' setting into a 'projectname' one.

jwilson23 gravatar imagejwilson23 ( 2018-04-12 15:49:42 +0200 )edit

Thanks for reporting this, we’re going to look into it and get back

alexpilotti gravatar imagealexpilotti ( 2018-04-12 16:24:28 +0200 )edit
0

answered 2018-04-12 14:24:44 +0200

jwilson23 gravatar image

Well it seems that replacing 'tenantname=' with 'projectname=' in the configuration helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-04-11 22:12:32 +0200

Seen: 83 times

Last updated: Apr 12