New Question
0

v-magine - Need more than 1 value to unpack? [closed]

asked 2016-11-26 06:20:31 +0200

Nebukazar gravatar image

updated 2016-12-06 16:15:20 +0200

Hi,

So far, we've been unable to install V-Magine on a 2012r2 STD hyperv host. When trying to get the OpenStack tools, we're getting the following error message "Need more than 1 value to unpack".

It appears to be a common error but so far, we haven't seen a fix for such problems.

When taking a deeper look at the vmagine logfile, we're seeing the following:

2016-11-25 16:06:06,555 DEBUG logging debug 1630 5492 AsyncLoopThread Connection info: ('10.214.33.3', 'root', None) 2016-11-25 16:06:06,555 DEBUG logging debug 1630 5492 AsyncLoopThread connecting 2016-11-25 16:06:07,234 DEBUG logging debug 1630 5492 AsyncLoopThread connected 2016-11-25 16:06:07,934 DEBUG logging debug 1630 5492 AsyncLoopThread OpenStack config: {'oslomessagingrabbit': {'rabbithosts': '', 'rabbituserid': '', 'rabbitpassword': ''}, 'glance': {'apiservers': ''}, 'keystoneauthtoken': {'admintenantname': '', 'adminpassword': '', 'adminuser': ''}, 'neutron': {'username': '', 'projectname': '', 'url': '', 'userdomainname': '', 'authurl': '', 'password': '', 'projectdomainname': ''}} 2016-11-25 16:06:23,496 ERROR logging error 1596 5492 AsyncLoopThread need more than 1 value to unpack Traceback (most recent call last): File "C:\Dev\v-magine\build\v-magine\out00-PYZ.pyz\vmagine.worker", line 703, in deployopenstack File "C:\Dev\v-magine\build\v-magine\out00-PYZ.pyz\vmagine.worker", line 353, in installlocalhypervcompute File "C:\Dev\v-magine\build\v-magine\out00-PYZ.pyz\vmagine.actions", line 271, in installhyperv_compute ValueError: need more than 1 value to unpack 2016-11-25 16:06:23,496 ERROR logging error 1596 5492 AsyncLoopThread need more than 1 value to unpack 2016-11-25 16:06:23,496 INFO logging info 1622 5492 AsyncLoopThread Killing pybootd 2016-11-25 16:06:23,497 ERROR logging error 1596 5492 AsyncLoopThread Exception in callback <task finished="" coro="&lt;coro()" done,="" defined="" at="" c:\dev\v-magine\build\v-magine\out00-pyz.pyz\trollius.coroutines:257=""> result=False>() 2016-11-25 16:06:23,497 ERROR logging error 1596 5492 AsyncLoopThread 'Task' object is not callable Traceback (most recent call last): File "C:\Dev\v-magine\build\v-magine\out00-PYZ.pyz\trollius.events", line 151, in _run TypeError: 'Task' object is not callable

Is there a way to fix the issue mentioned above ? Please let us know if you require further information.

Thanks! -Luc

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Nebukazar
close date 2016-12-09 21:24:53.357312

3 answers

Sort by » oldest newest most voted
0

answered 2016-12-01 20:11:17 +0200

Nebukazar gravatar image

For those who are getting those errors, I have been able to fix it by using a different root's password through the v-magine installer. I ended up using an alpha-numeric password with no special characters.

edit flag offensive delete link more
0

answered 2016-11-27 04:52:56 +0200

eckdd gravatar image

I ran into a similar error. Fixed it by ensuring that the external IP address on the host was static.

edit flag offensive delete link more

Comments

host = hyperv host running the rdo ? if so, it is already a fixed IP. Only the RDO is having an external DHCP IP.

Nebukazar gravatar imageNebukazar ( 2016-11-28 03:51:59 +0200 )edit
0

answered 2016-12-02 14:30:52 +0200

alexpilotti gravatar image

updated 2016-12-03 11:56:04 +0200

Thanks, this helped pointing us in the right direction as we were not able to reproduce the issue when testing. A fix is under way, the issue was related to escaping issues when calling Bash on the Linux controller from Python with some special chars. The characters affected are the following: \ ! "

A fix has been released, with updated version 2016.1.0.4.

Issue tracking for v-magine is now hosted on github, more details on the issue and the fix are available here: https://github.com/cloudbase/v-magine...

Note: after deployment, when accessing the SSH console, sourcing keystonercadmin or keystonercdemo gives also a error due to missing Bash escaping in OS_PASSWORD, it can be simply solved by editing the keystonerc files. This is an RDO bug, to be reported at the project's bug tracker.

edit flag offensive delete link more

Comments

Hi, Downloaded today latest 2016.1.0.4 v-magine from webpage, used password with only small letter and digits and still have errors: https://s11.postimg.org/iob0gc6b7/image.jpghttps://s17.postimg.org/6uvfno533/image.jpg Here detailed log: http://pastebin.com/x5xn1VqA

sztyrlic111 gravatar imagesztyrlic111 ( 2016-12-04 12:02:57 +0200 )edit

When I rebooted vm got interesting errors: https://s15.postimg.org/697buizh7/image.jpg

sztyrlic111 gravatar imagesztyrlic111 ( 2016-12-04 12:18:06 +0200 )edit

Hi, the timeout issue can occur during the RDO VM reboot. This can happen if the VM is slow on reboot, as the v-magine installer tries to reconnect the the VM, it times out. We had this in the past and we increased the time out. Is this the case, the VM is slow on reboot?

danardelean gravatar imagedanardelean ( 2016-12-05 10:14:57 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2016-11-26 06:20:31 +0200

Seen: 70 times

Last updated: Dec 03 '16